Helix scheduled maintenance
Completed
The scheduled maintenance has been completed.
Posted Apr 07, 2021 - 23:00 AEST
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 07, 2021 - 22:02 AEST
Scheduled
MedicalDirector Helix will be unavailable due to scheduled maintenance for approximately 1 hour, tonight from 10pm AEST.
Posted Apr 07, 2021 - 14:27 AEST
This scheduled maintenance affected: Helix.