Helix: glitch - Identified
Incident Report for MedicalDirector Product Status
Resolved
This incident has been resolved.
Posted May 12, 2022 - 14:57 AEST
Identified
The issue has been identified and a fix is being implemented.
Posted May 09, 2022 - 09:58 AEST
Investigating
We are currently experiencing a glitch with Helix.

The issue has been identified and our engineering and operations teams are working hard to resolve it as soon as possible. Every effort is being made to minimise the impact to you, your staff and your patients.

The issue is related to patient allocation in the task tab, tasks are showing up without their assigned patient, leading to potential confusion.

We will send an update shortly as soon as more information becomes available and we apologise for any inconvenience.
Posted May 09, 2022 - 09:58 AEST
This incident affected: Cloud Products (Helix).