3rd Party Service Unavailable - Medicare Australia
Incident Report for MedicalDirector Product Status
Resolved
This incident has been resolved.
Posted Mar 15, 2023 - 13:04 AEDT
Monitoring
Medicare Australia has advised services are restored and users should be seeing signs of recovery at this moment. We will continue to monitor the situation.
Posted Mar 14, 2023 - 12:19 AEDT
Identified
Medicare Australia services are currently experiencing an outage, impacting MedicalDirector Clinical, Pracsoft, Bluechip and Helix products.

We are currently attempting to resolve the issue with Medicare Australia.
Posted Mar 13, 2023 - 12:53 AEDT
This incident affected: Cloud Products (Helix), On Premise Products (MD Clinical, Pracsoft, Bluechip), and Third Party Services (Medicare).