Medicare services
Incident Report for MedicalDirector Product Status
Resolved
This incident has been resolved.
Posted May 05, 2021 - 11:14 AEST
Identified
Medicare is currently experiencing a Degradation of Services. If you are experiencing Online Claiming Errors in your application, please try again later.
Posted Apr 30, 2021 - 10:07 AEST
This incident affected: Third Party Services (Medicare).